You are here: Home

Ασκηση ΠΜ12 - Φυσσαλίδα T2 Featured

Rate this item
(1 vote)

Στον αλγόριθμο ταξινόμησης με τη μέθοδο της φυσσαλίδας υπάρχει το εξής μειονέκτημα: οι επαναλήψεις συνεχίζονται «στα τυφλά», ακόμη κι αν ο πίνακας έχει ταξινομηθεί από πολύ πιο πριν. Μία βελτιωμένη έκδοση της φυσσαλίδας είναι αυτή που ακολουθεί παρακάτω. Αν ο πίνακας «περαστεί» μία φορά και δεν προκύψει αντιμετάθεση, τότε ο αλγόριθμος τερματίζεται.


Αλγόριθμος Φυσσαλίδα_Τ2

 

Δεδομένα / / Ν, Α / /

αντιμετάθεση <-- αληθής

i <-- 2

Όσο (i < = Ν) και (αντιμετάθεση = αληθής) επανάλαβε

αντιμετάθεση <-- ψευδής

Για j από Ν μέχρι i με_βήμα –1

Αν Α[j – 1] > A[j] τότε

temp <-- Α[j – 1]

A[j – 1] <-- A[j]

A[j] <-- temp

αντιμετάθεση <-- αληθής

Τέλος_αν

Τέλος_επανάληψης

i <-- i + 1

Τέλος_επανάληψης

Αποτελέσματα / / Α / /

Τέλος Φυσσαλίδα_Τ2



 

Sharesubmit to redditShare on LinkedIn
More in this category: « Prev Next »

Add comment