You are here: Home

Ασκηση Ε11 - Τέλη κυκλοφορίας στα ιδιωτικής χρήσεως Featured

Rate this item
(2 votes)

Το υπουργείο οικονομικών επιβάλλει τέλη κυκλοφορίας στα ιδιωτικής χρήσεως επιβατηγά οχήματα (αυτοκίνητα και δίκυκλα) ανάλογα με τον κυβισμό τους σύμφωνα με τον παρακάτω πίνακα :

να γραφεί αλγόριθμος ο οποίος :

α) να διαβάζει τον τύπο του οχήματος ( Δ = Δίκυκλο, Α = Αυτοκίνητο ) και τον κυβισμό του.

β) να υπολογίζει τα αντίστοιχα τέλη κυκλοφορίας του οχήματος

γ) να εμφανίζει το ποσό που αναλογεί

Σημείωση : Να θεωρήσετε θετικό τον αριθμό του κυβισμού

Τύπος Οχήματος
Κυβισμός
Τέλος Κυκλοφορίας
Δίκυκλα
Μέχρι 500 cc
50 €
Δίκυκλα
Από 501cc και άνω
100 €
Αυτοκίνητα
Μέχρι 1358 cc
200 €
Αυτοκίνητα
Από 1359 μέχρι 1750 cc
 220€
Αυτοκίνητα
Από 1751 μέχρι 2000 cc
250 €
Αυτοκίνητα
Από 2000cc και άνω
600 €

 


Λύση:

Αλγόριθμος Ασκηση_Ε11

Διάβασε Τύπος, Κυβισμός

Αν Τύπος = “Δ” τότε

    Αν Κυβισμός<= 500 τότε
         Τέλη <-- 50

    αλλιώς
         Τέλη <-- 100

    Τέλος_αν

αλλιώς_αν Τύπος = “Α”

   Αν Κυβισμός<= 1358 τότε
       Τέλη <-- 100

   αλλιώς_αν Κυβισμός<= 1750 τότε
      Τέλη <-- 150

   αλλιώς_αν Κυβισμός<= 2000 τότε
     Τέλη <--200
 
   αλλιώς
     Τέλη  <-- 300

   Τέλος_αν

Τέλος_αν

Εμφάνισε Τέλη

Τέλος Ασκηση_Ε11

Sharesubmit to redditShare on LinkedIn
More in this category: « Prev Next »

Add comment