You are here: Home

Ασκηση ΕΠ5 - Δομή Επανάληψης

Rate this item
(0 votes)

Να γραφεί αλγόριθμος που να υπολογίζει όλες τις ακέραιες λύσεις της εξίσωσης αx3+βx2+γx+δ στο διάστημα [–100, 100]. Ο αλγόριθμος θα πρέπει να είναι «έξυπνος» και στην περίπτωση που βρει και τις τρεις λύσεις, θα πρέπει να σταματάει την αναζήτηση.

 


Λύση:

Αλγόριθμος Τριτοβάθμια

Λύσεις <-- 0

X <-- –100

Εμφάνισε “Δώσε μου τους συντελεστές α, β, γ και δ: ”

Διάβασε α, β, γ, δ

Όσο (Λύσεις < 3) και (Χ < = 100) επανάλαβε

     Υ <-- α*Χ^3 + β*Χ^2 + γ*Χ + δ

      Αν (Υ = 0) τότε

          Εμφάνισε “Λύση της εξίσωσης: ”, Χ

           Λύσεις <-- Λύσεις + 1

      Τέλος_αν

      Χ <-- Χ + 1

Τέλος_επανάληψης



Εμφάνισε “Πλήθος λύσεων που βρέθηκαν: ”, Λύσεις

Τέλος Τριτοβάθμια

 


 

 

Sharesubmit to redditShare on LinkedIn
More in this category: « Prev Next »

Add comment