You are here: Home

Ασκηση ΕΠ3 - Δομή Επανάληψης

Rate this item
(2 votes)

Δίνεται τμήμα αλγορίθμου:

       Χ <-- 13

      Οσο Χ<=20 επανάλαβε

             εμφάνισε Χ

             Χ <-- Χ+2

     Τέλος_επανάληψης

     εμφάνισε Χ

α) Για ποια τιμή του Χ τερματίζεται ο αλγόριθμος;

β) Κατά την εκτέλεση του τμήματος αλγορίθμου ποιες είναι οι τιμές του Χ που θα εμφανιστούν;

γ) Να γραφεί το παραπάνω τμήμα αλγορίθμου με τη χρήση των εντολών Αρχή_επανάληψης ….. μέχρις_ότου και Για ….από …. μέχρι , έτσι ώστε να εμφανίζονται οι ίδιες ακριβώς τιμές.

 

 


Λύση:

α) Ο αλγόριθμος τερματίζεται για Χ=21

β) Οι τιμές που θα εμφανιστούν είναι 13, 15, 17, 19, 21

γ)   

i)

Χ <-- 13
Αρχή_επανάληψης
   εμφάνισε Χ
   Χ <-- Χ+2
Μέχρις_ότου Χ>20

εμφάνισε Χ

 

ii)

Για Χ από 13 μέχρι 21 με_βήμα 2
   εμφάνισε Χ
Τέλος_επανάληψης



 

Sharesubmit to redditShare on LinkedIn
More in this category: « Prev Next »

Add comment