You are here: Home

Ασκηση ΕΠ2 - Δομή Επανάληψης

Rate this item
(1 vote)

Να γραφεί αλγόριθμος που να διαβάζει το πολύ 10 αριθμούς και να υπολογίζει:

Α) το άθροισμα τους

Β) το πλήθος τους

Γ)το μέσο όρο τους

Στην περίπτωση που διαβάσει την τιμή 5, σταματάει την εκτέλεση και εμφανίζει τα τρέχοντα αποτελέσματα.

 

 

 


Λύση:

Ο αλγόριθμος αυτός εμπεριέχει 2 συνθήκες τερματισμού και χρειάζεται προσοχή στην επιλογή της κατάλληλης εντολής επανάληψης, για να έχουμε πάντα σωστά αποτελέσματα, λαμβάνοντας υπ’ όψιν ότι μπορεί να δοθεί απ’ ευθείας το 5 σαν πρώτος αριθμός. Η εκφώνηση δε διευκρινίζει αν θέλουμε ή όχι να συνυπολογίζεται ο αριθμός 5 στο άθροισμα, πλήθος και μέσο όρο. Συνήθως οι τιμές τερματισμού θεωρούνται ως τιμές μη επιθυμητές για τις πράξεις και ο παρακάτω αλγόριθμος υλοποιεί αυτή την εκδοχή.

Αλγόριθμος Αριθμοί

Διάβασε x
i <-- 1


Άθροισμα <-- 0

Όσο i <= 10 και x <> 5 επανέλαβε
   Άθροισμα <-- Άθροισμα + x
   i <-- i + 1
   Διάβασε x            
Τέλος_επανάληψης

Αν i = 1 τότε
  Εμφάνισε ‘ Δώσατε ως πρώτο αριθμό το 5 ‘
Αλλιώς
  ΜΟ <-- Άθροισμα / i
  Εμφάνισε Άθροισμα, i, ΜΟ
Τέλος_αν

Τέλος Αριθμοί



Sharesubmit to redditShare on LinkedIn
More in this category: « Prev Next »

Add comment