You are here: Home

Ασκηση ΠΜ13 - Φυσσαλίδα Τ3 Featured

Rate this item
(1 vote)

Μία άλλη παραλλαγή της φυσσαλίδας, παρόμοια με την παραπάνω, φαίνεται στη συνέχεια:

 

Αλγόριθμος Φυσσαλίδα_Τ3

Δεδομένα / / Ν, Α / /

!Τετράδιο του μαθητή, σελ. 101

Αρχή_επανάληψης

flag <-- ψευδής

Τ <-- 0

Για i από 1 μέχρι Ν–1

Αν Α[i] > A[i + 1] τότε

temp <-- Α[i]

A[i] <-- A[i + 1]

A[i + 1] <-- temp

T <-- i

Τέλος_αν

Τέλος_επανάληψης

Ν <-- Τ

Μέχρις_ότου Τ = 0

Αποτελέσματα / / Α / /

Τέλος Φυσσαλίδα_Τ3

Sharesubmit to redditShare on LinkedIn
More in this category: « Prev

Add comment